Opencart

Shopping Cart: OpenCart
Compatible Versions: 1.5.x

For Opencart 2.0 and later, Download plugin for Opencart 2.0
For older versions of Opencart, Download plugin for older versions of Opencart

This plugin requires PDO.
PDO (PHP Data Objects) is a module for PHP that our Opencart plugin uses. PDO comes standard with PHP installations, unless it is specifically compiled without it. Some hosting services provide PHP bundles without PDO.
Please see this guide on installing PDO into your PHP:
http://php.net/manual/en/pdo.installation.php

Or alternatively, contact your hosting provider - they should be able to install it for you.

Installation Instructions:

1. Backup your version of OpenCart, and any extensions.

2. Copy the downloaded directories “admin” and “catalog” into your installation of OpenCart.

3. If prompted, overwrite any existing files or folders present.

4. Login to your OpenCart admin panel, and navigate to the POLi Payments module in Extensions > Payments.

5. Click the “install” button.

6. Click the “edit” button that will have appeared where the “install” button was.

7. In the admin panel, fill out the following fields:

  • Merchant Code (this is on your Merchant Account Record attached to your Welcome email)
  • Authentication Code (this is on your Merchant Account Record attached to your Welcome email)
  • Enable POLi Internet Banking – please ensure you mark this field as “Enabled”

Then click Save.

Please test a transaction by choosing POLi at the checkout of your shop.
Please progress through the transaction using iBank, our fictional test bank. Use these credentials:
Username: DemoShopper
Password: DemoShopper

Once you are satisfied, please contact implementation@polipayments.com so we can set the service live for you.

opencart.txt · Last modified: 2017/01/20 10:11 (external edit)